Get Table

  • Last Post 07 December 2020 posted this 02 December 2020

Hi Team!

I am trying to read table from Chrome browser using Get Table activity. I have already switched Target Platform to 'web' and I always get the same error: 

If I am swtiching target platform to 'automatic' or 'windows' then I don't have any error, but output data table is simply blank. What can be the reason for my problem? Also, is it possible to add better explanation of the type of error that occured in my workflow? For now it sometimes hard to understand the type of error from text "An error occured during execution".

If GetTable will not work for me, what can you suggest to use apart from this tool? I have tried to use GetInnerText and GetInnerHTML methods, however, I did not find any suitable parser for ordinal text and HTML. 

Order By: Standard | Newest | Votes
Intellibot Support posted this 02 December 2020


Can you please try to do the same using Chrome connector instead of using Actions(UI).

Please find the documentation link for chrome connector (

You can identify the element as Table and use the GetTable component to get the output as DataTable.

Thanks & Regards,

Intellibot Support. posted this 03 December 2020

Hi! Thanks for your reply. 

I am sorry, but how specifically do I identify element as Table? I did not find how to do it in your documentation. Maybe you could suggest something? 



Intellibot Support posted this 04 December 2020


Please find the attachment below on how to extract table data using chrome connector

Hope it helps!

Please revert us for any further clarifications.

Thanks & Regards,

Intellibot Support. posted this 07 December 2020

Thanks for your reply! 

Unfortunatelly, the suggested solution did not help. For some reason Chrome Connector cannot recognize table as a parent element. Even though CSS selector looks like this: html > body > div:nth-of-type(2) > div:nth-of-type(4) > div > div:nth-of-type(2) > div > div:nth-of-type(3) > div > div:nth-of-type(2) > table > thead Chrome connector still does not offer me an option to use GetTable. I even corrected selector mannually by deleting > thead section, but still no option for me to use GetTable. 

However, for now I found alternative solution: I am using GetOutterText component and pasting text into Excel. After this I extract DataTable from Excel 

  • Liked by