SOLVED: System Process -> StartNew: Python process completes despite error

  • Last Post 26 August 2019
  • Topic Is Solved
RepCat posted this 18 August 2019

EDIT: Solved - I changed the executable from python.exe to pythonw.exe, and the error is gone. I'm leaving the post below intact in case it might help someone else.

Hi, I'm experimenting with Python and Intellibot. I can start a Python process (*.pyw) with "StartNew"; "Start App", which I thought might work, doesn't.

Although Python runs the process and exits, an error is thrown. I've seen similar results with other RPA platforms when the process to be started does not immediately produce a GUI (i.e. "WaitForInputIdle" fails). This doesn't affect any functionality for me at the moment, I'm curious as to how I might avoid the error.

Thanks in advance for all help!

Below are some screenshots of my workflow, the result, and the error:

Starting Python

Again, thanks for all help.




Attached Files

Order By: Standard | Newest | Votes posted this 19 August 2019

Hi Winter,

Thank you for reaching out to the Intellibot Forum Support Team.

If you need any further assistance while learning Intellibot, please contact us.

Thanks & Regards,

Alphonsa Kalapala.

  • Liked by
RepCat posted this 26 August 2019

There is apparently no way for me to mark my own answer as a solution when I solve it.